Search found 68 matches

by LANSAGuru
Tue Aug 29, 2017 1:23 am
Forum: Questions & Answers
Topic: [SOLVED] Dynamic Multi-lingual
Replies: 4
Views: 1754

[SOLVED] Dynamic Multi-lingual

Multilingual variables get burned into a compiled program. I have a use case where a set of menu's is loaded dynamically from a file. The file will have menu option and a description, but I want the description to be multilingual value. So I want to put the name of the multilingual variable into the...
by LANSAGuru
Fri Aug 25, 2017 12:29 am
Forum: Questions & Answers
Topic: VLF-ONE SWITCH question
Replies: 8
Views: 3043

Re: VLF-ONE SWITCH question

Joe, I like the idea. In VL this is trivial...you would normally just add a mthroutine and run it. In this case however I don't know how to get a handle to the filter to do that. I like the idea of being able to kick of an ARBITRARY mthroutine in the filter or command a handler. It is possible every...
by LANSAGuru
Wed Aug 23, 2017 2:50 pm
Forum: Questions & Answers
Topic: VLF-ONE SWITCH question
Replies: 8
Views: 3043

Re: VLF-ONE SWITCH question

Some of this appears to not be in the documentation yet. ..Dataitem(#NewEmployeeItem) #NewEmployeeItem.avExecuteDefaultCommand works beautifully the Callerreference, SwitchCallerReference parms look very useful. SwitchCallerReference is not accesible within the filter, so for this case I would need ...
by LANSAGuru
Wed Aug 23, 2017 7:43 am
Forum: Questions & Answers
Topic: VLF-ONE SWITCH question
Replies: 8
Views: 3043

VLF-ONE SWITCH question

Use Case: Two Business Objects share a command handler. The command handler adds records to a file(s) and adds an instance to BO #1 (this command handler is attached to a command for both BO #1 and BO #2). After adding the record(s) we clear the instance list for BO #1, switch to it from BO #2 if we...
by LANSAGuru
Wed Jul 26, 2017 7:48 am
Forum: Questions & Answers
Topic: [SOLVED] Set a specific Unicode Field
Replies: 2
Views: 1593

Re: Set a specific Unicode Field

Stewart, I see why I did not find this. It is buried in the primitives definition in the doco. It also does not define what the input is really. it appears to me to be the decimal representation of a single Unicode Character code point. But this does work. It does appear to return the correct Unicod...
by LANSAGuru
Tue Jul 25, 2017 12:56 am
Forum: Questions & Answers
Topic: [SOLVED] Set a specific Unicode Field
Replies: 2
Views: 1593

[SOLVED] Set a specific Unicode Field

Does anyone know how to set a Unicode Field to a specific value in RDMLX code? 1. I do not want to read a Unicode database field from a table and move that value in, I want to set an arbitrary Unicode value like u+nnnn and cast it into a Unicode file. 2. .asSQLNativeString moves a given unicode valu...
by LANSAGuru
Thu Jun 29, 2017 1:29 am
Forum: Questions & Answers
Topic: How do you mark a question as SOLVED?
Replies: 2
Views: 985

Re: How do you mark a question as SOLVED?

I don't see a button to mark as solved. I think you have to edit the article title.
by LANSAGuru
Thu Jun 29, 2017 12:07 am
Forum: Questions & Answers
Topic: How do you mark a question as SOLVED?
Replies: 2
Views: 985

How do you mark a question as SOLVED?

How do you mark a question as solved?
by LANSAGuru
Wed Nov 30, 2016 5:40 am
Forum: Questions & Answers
Topic: Case Insensitive SELECT on IBM i
Replies: 4
Views: 2154

Re: Case Insensitive SELECT on IBM i

like '%ABC%'

will find

ABCXYZ
123ABC
ttABCtt

generic ABC

will find

ABCXYZ
not the other 2

In your specific case (above) they are in fact identical.
by LANSAGuru
Wed Nov 30, 2016 2:55 am
Forum: Questions & Answers
Topic: Case Insensitive SELECT on IBM i
Replies: 4
Views: 2154

Re: Case Insensitive SELECT on IBM i

Your 2 querys are not exactly the same. Generic does something different than like. Like searchs the entire field for a match, the generic starts at the beginning of the fied. For a LANSA controlled file. To do this you need an index. The index needs to be built over a real field, so typically you s...
by LANSAGuru
Thu Nov 17, 2016 4:15 am
Forum: Questions & Answers
Topic: VL WEB Model B (Multi-Tier)
Replies: 3
Views: 1820

Re: VL WEB Model B (Multi-Tier)

If you have deployed a webevent or WAM application in the past there is no difference in how you deploy. If you don't actually have a functional mult-tier setup functioning, you should contact your local LANSA support desk for help or refer to the documentation for multi-tier setup in the installing...
by LANSAGuru
Thu Nov 17, 2016 3:19 am
Forum: Questions & Answers
Topic: Source Recovery
Replies: 8
Views: 3305

Re: Source Recovery

To get the object back in the repository you need the source code form the internal LANSA repository files. If the object exists in a different LANSA install or a different partition in the same install (I am not certain how you have your system setup here) you would do an export from production int...
by LANSAGuru
Tue Nov 15, 2016 2:47 am
Forum: Questions & Answers
Topic: AWS Development Environment
Replies: 3
Views: 1731

Re: AWS Development Environment

Did this start at 13.2 and then go through updates or was this started at 14.0 and then get upgraded to 14.1? I know if an image is copied, you can no longer retrieve the administrator password. However I am not sure how the update process occurs, but I am imagining that this prevents the ability to...
by LANSAGuru
Sat Oct 29, 2016 4:58 am
Forum: Questions & Answers
Topic: SOAP server running on HTTPS
Replies: 8
Views: 2975

Re: SOAP server running on HTTPS

I found out some new information. The LANSA BIF which execute LANSA to process you inbound JSMDIRECT request only intercepts certain http headers and any that start with HTTP_ automatically. However, there is an exit program you can call from the LANSA function which will retrieve any environment va...
by LANSAGuru
Fri Oct 28, 2016 2:15 am
Forum: Questions & Answers
Topic: SOAP server running on HTTPS
Replies: 8
Views: 2975

Re: SOAP server running on HTTPS

I see, you are not running HTTPS yet. I also see that only some of the headers are available to you, and none provide what you are looking for. Setup SSL and see if you get some additional headers. Then you blank would indicate not SSL while a value in the new variable would indicate SSL. I see port...
by LANSAGuru
Tue Oct 25, 2016 1:38 am
Forum: Questions & Answers
Topic: SOAP server running on HTTPS
Replies: 8
Views: 2975

Re: SOAP server running on HTTPS

Attach a complete set of Integrator traces. I am interested primarily in the content of protocol.txt. You are not able to retrieve any environment variables which are not specifically populated, so that one may not be getting populated. Everything that is available should be in the protocol.txt file...
by LANSAGuru
Sat Oct 22, 2016 3:41 am
Forum: Questions & Answers
Topic: SOAP server running on HTTPS
Replies: 8
Views: 2975

Re: SOAP server running on HTTPS

You get one of the http header properties for the request. From the doco, here is how to get a property. GET PROPERTY(SOAPACTION) http://docs.lansa.com/14/en/lansa093/index.htm#lansa/intengb7_1725.htm#intengb7_1725 Here is a list of headers for Apache on IBMi https://publib.boulder.ibm.com/iseries/v...
by LANSAGuru
Fri Oct 21, 2016 8:13 am
Forum: Questions & Answers
Topic: Showing the TradeMark symbol
Replies: 5
Views: 2175

Re: Showing the TradeMark symbol

Some caveats. This only works if the target field is Unicode (server module side) which you say is where you are getting the value from. It only works if you are scanning all values for predefined html entities and hard coding the results. If you have many of these (different types of html entities)...
by LANSAGuru
Fri Oct 21, 2016 7:36 am
Forum: Questions & Answers
Topic: Showing the TradeMark symbol
Replies: 5
Views: 2175

Re: Showing the TradeMark symbol

So the deal is you are attempting (I assume) to put html markup into a label. Raw html markup itself needs to be included as raw html markup. For instance ™ is NOT the trademark symbol. Instead it is the html markup for the trade symbol So you need to use the html container control. It is like...
by LANSAGuru
Fri Oct 21, 2016 7:27 am
Forum: Questions & Answers
Topic: PRIM_TILE content alignment
Replies: 2
Views: 1533

Re: PRIM_TILE content alignment

Content width makes no sense in this context. Tiles are meant to grow and shrink in a given area to fit in as many tiles as possible so there is no predefined content to fit a width to. You want to use fit to width instead. In an nutshell you want to size the tile to content height and fit to width....