Search found 51 matches

by HMJust
Fri Feb 24, 2017 11:27 pm
Forum: Questions & Answers
Topic: Remove the "webroutine" part of JSON content
Replies: 0
Views: 1156

Remove the "webroutine" part of JSON content

I have finally gotten to generating JSON with a WAM. I have a question, is it possible to exclude the "webroutine" part of the JSON content? Like in this: { "webroutine":{ "context":{ "action-request":"/CGI-BIN/lansaweb", "dec-separator":",", "images-path":"/IMAGES", "iso-lang":"", "language":"NAT",...
by HMJust
Fri Feb 24, 2017 6:13 pm
Forum: Questions & Answers
Topic: LANSA Integrator & 3rd Party SOAP Services
Replies: 8
Views: 1785

Re: LANSA Integrator & 3rd Party SOAP Services

My initial thinking (based on your description and not seeing your code) is that changing the order of the fragments could only be relevant in your code, not in the setup in Integrator. Have you tried the sample RDML(X) that Integrator generates? I usually use that as a starting point and "just" fil...
by HMJust
Thu Feb 23, 2017 7:34 pm
Forum: Questions & Answers
Topic: LANSA Integrator & 3rd Party SOAP Services
Replies: 8
Views: 1785

Re: LANSA Integrator & 3rd Party SOAP Services

That sounds strange. I have gotten a couple of SOAP clients up and running with Lansa Integrator and I can't recognize that situation. So, you have created a solution with the SOAP Agent Wizard tool, right? And picked the WSDL for the service? In the wizard, the operations are listed in the left han...
by HMJust
Thu Feb 23, 2017 7:18 pm
Forum: Questions & Answers
Topic: WAM SessionStatus not working for me
Replies: 1
Views: 707

Re: WAM SessionStatus not working for me

First mistake is obviously that I thought the WAM session was invalidated on the server when I set

Code: Select all

SessionStatus := Invalid
. It isn't so a new request with the old session key can access the old WAM session.
by HMJust
Thu Feb 23, 2017 1:45 am
Forum: Questions & Answers
Topic: WAM SessionStatus not working for me
Replies: 1
Views: 707

WAM SessionStatus not working for me

I have a site built with WAM using sessions for logins. One WAM (LOGIN) is used for login and logout, like this: Webroutine Name(StartPage) Onentry(*sessionstatus_none) Web_Map For(*BOTH) Fields(#WAWUSR #wawpwd) ... Endroutine * validate login - no interface for this routine Webroutine Name(Validate...
by HMJust
Tue Feb 14, 2017 7:17 pm
Forum: Questions & Answers
Topic: Lansa Editor changing my code
Replies: 0
Views: 977

Lansa Editor changing my code

I have experienced this in a couple of situations and it does bother me. I know that I can work around this and I obviously have to. Last year I had one variant of it and now I just experienced this: https://lansa123.files.wordpress.com/2017/02/2017-02-14_090415.png In short: Pings (') in my XSLT is...
by HMJust
Mon Feb 06, 2017 11:06 pm
Forum: Questions & Answers
Topic: A question about doing development on laptops
Replies: 4
Views: 1509

Re: A question about doing development on laptops

I don't usually do this, but when I am working from home I connect to my PC at work. So I might do this once or twice every month. I run at 1920x1200 on the laptop. I prefer the bigger resolution I have a work and I really appreciate having two monitors.
by HMJust
Wed Jan 04, 2017 7:44 pm
Forum: Questions & Answers
Topic: Generate MD5 in a server module (Windows)
Replies: 8
Views: 2587

Re: Generate MD5 in a server module (Windows)

If you look at my example at https://lansa123.wordpress.com/2016/12/ ... shservice/ you can just replace the SHA256 with MD5. That should work.

Remember, only use MD5 if it is an external requirement. Use SHA256 or better if you need cryptographic protection.
by HMJust
Wed Dec 28, 2016 7:39 pm
Forum: Questions & Answers
Topic: Integrator SOAP Server - Unsupported service error
Replies: 2
Views: 1228

Re: Integrator SOAP Server - Unsupported service error

Well, obviously there is a problem with the SOAP server so I suggest you confine yourself to testing it with SoapUI till you get it working - that means you don't have to worry about any possible errors in your SOAP client. When you say you created an entry in the JSM service, do you mean the Lansa ...
by HMJust
Wed Dec 28, 2016 4:58 pm
Forum: Questions & Answers
Topic: autoincrement primary key
Replies: 4
Views: 2405

Re: autoincrement primary key

Having spent many years in an environment where we used an integer identity field I too have come to prefer GUIDs. While integers are easy in many ways, the uniqueness across installations and files of GUIDs make them more suitable over time.
by HMJust
Wed Dec 21, 2016 6:43 pm
Forum: Questions & Answers
Topic: Generate MD5 in a server module (Windows)
Replies: 8
Views: 2587

Re: Generate MD5 in a server module (Windows)

As you are running on Windows, and do not wish to use the Lansa Integrator, I would suggest using a .NET component. http://docs.lansa.com/14/en/lansa015/index.htm#lansa/l4wtgu04_0300.htm I haven't done this myself, but I understand that should be possible. The standard MD5 component is documented he...
by HMJust
Wed Nov 23, 2016 11:39 pm
Forum: Questions & Answers
Topic: Source Recovery
Replies: 8
Views: 2739

Re: Source Recovery

Alternatively, make the move to using version control. Which brings me to a question I've had for some time. We use a master on a system i with slaves on development machines. We also use a central slave SQL server "between" us and the master. As far as I understand, we cannot use the file based ve...
by HMJust
Mon Oct 31, 2016 11:56 pm
Forum: Suggestions for Product Enhancements
Topic: Can we have REGEX(Regular Expressions) method for strings?
Replies: 3
Views: 2192

Re: Can we have REGEX(Regular Expressions) method for strings?

I can only say that I would really appreciate RegExes in RDMLX :)
by HMJust
Mon Oct 31, 2016 6:53 pm
Forum: Questions & Answers
Topic: SOAP server running on HTTPS
Replies: 8
Views: 2329

Re: SOAP server running on HTTPS

Wow, that looks really interesting. Thank you. I will not get to try it out right now - time restraints - but hope to get back to it later. In the mean time I have a solution that works - I set up a webserver that only runs SSL, set the service to only respond on that site and added a check for the ...
by HMJust
Wed Oct 26, 2016 10:03 pm
Forum: Questions & Answers
Topic: SOAP server running on HTTPS
Replies: 8
Views: 2329

Re: SOAP server running on HTTPS

Regarding the first option, I have tried to upload the files I think you were talking about: http://soap.rto.dk/HTTP_KEYWORDS.TXT and http://soap.rto.dk/HTTP_RESPONSE_PROTOCOL.TXT . Currently the request is performed on HTTP and I would have expected the HTTPS property to have an OFF value. Other fi...
by HMJust
Tue Oct 25, 2016 12:11 am
Forum: Questions & Answers
Topic: SOAP server running on HTTPS
Replies: 8
Views: 2329

Re: SOAP server running on HTTPS

Further on GET PROPERTY:

Code: Select all

Change Field(#JSMXCMD) To('GET PROPERTY(HTTPS)')
returns nothing

If I use USER-AGENT, SERVER-NAME or SERVER-PROTOCOL (note the hyphens, not underscores), I do get a value into #JSMXMSG, so I expect that I am using it at least sort-of correctly.
by HMJust
Mon Oct 24, 2016 5:26 pm
Forum: Questions & Answers
Topic: SOAP server running on HTTPS
Replies: 8
Views: 2329

Re: SOAP server running on HTTPS

Ah, great. That includes a lot of properties I might use at a later time. Only problem is, I don't know exactly how to do that. I do Change Field(#JSMXCMD) To('SERVICE_LOAD SERVICE(SOAPServerService) SERVICE_CONTENT(*HTTP) TRACE(*YES)') Use Builtin(JSMX_COMMAND) With_Args(#JSMXHDLE1 #JSMXCMD) To_Get...
by HMJust
Fri Oct 21, 2016 8:53 pm
Forum: Questions & Answers
Topic: SOAP server running on HTTPS
Replies: 8
Views: 2329

SOAP server running on HTTPS

(those who follow the forum will see that my project is progressing) I now have a SOAP server running and it works. I would like this service to be exposed on HTTPS (on our System i) and I expect we can manage that. However, I would like to be able to determine, from my function, if it is using HTTP...
by HMJust
Fri Oct 21, 2016 5:49 pm
Forum: Questions & Answers
Topic: Single standalone webpage on System i
Replies: 7
Views: 2308

Re: Single standalone webpage on System i

Thank you. I think you understood what I was trying to say - right now I am a bit committed on this task but I will look into that way later.
by HMJust
Thu Oct 20, 2016 11:54 pm
Forum: Questions & Answers
Topic: Single standalone webpage on System i
Replies: 7
Views: 2308

Re: Single standalone webpage on System i

Granted, I got a bit confused there and see that the mismatch between the UI and the documentation isn't as big as I thought. And I am getting a response, so that's something.