Search found 53 matches

by lawingo
Thu Feb 14, 2019 4:35 am
Forum: Questions & Answers
Topic: Set Focus to Cell in Grid
Replies: 2
Views: 1945

Re: Set Focus to Cell in Grid

Bingo!

Thanks for your help.
by lawingo
Tue Feb 12, 2019 3:18 am
Forum: Questions & Answers
Topic: Set Focus to Cell in Grid
Replies: 2
Views: 1945

Set Focus to Cell in Grid

Hopefully an easy Question: I want to select the 1st Record in a grid and set focus to a cell in the 1st Row. In my example, the cell I want to set focus to is "GridColumn6". The code below selects the 1st record and it visually sets focus to the cell I want but I still have to click in the Cell in ...
by lawingo
Sat Oct 13, 2018 1:26 am
Forum: Questions & Answers
Topic: Insert return_rrn not working
Replies: 2
Views: 985

Re: Insert return_rrn not working

Are the records actually inserting into the table? - Meaning could it be trying to insert and the insert fails and returns a bogus record?

Also - what is the definition of "WK_Number"? I typically use "PRIFILRRN" as the return field for the RRN. It's Decimal(15,0).
by lawingo
Fri Sep 28, 2018 6:23 am
Forum: Questions & Answers
Topic: Passing Lists
Replies: 4
Views: 1496

Re: Passing Lists

Maybe I spoke to soon.... Can anyone post an example of a Reusable Part Executing a Server Module and passing a List? Now in my RP it doesn't recognize the list map. It says: "Method Execute does not contain parameter name List." Server Module: Define_Com Class(#PRIM_ACOL<#dwlg_do>) Name(#gUserList)...
by lawingo
Fri Sep 28, 2018 5:40 am
Forum: Questions & Answers
Topic: I need a bit of feedback on O/S Versions
Replies: 1
Views: 875

Re: I need a bit of feedback on O/S Versions

Not many here. Most everything is 64bit.

Chad
by lawingo
Fri Sep 28, 2018 5:39 am
Forum: Questions & Answers
Topic: Passing Lists
Replies: 4
Views: 1496

Re: Passing Lists

Ha! Thanks. That worked. Well that makes a lot of sense!

Best,
Chad
by lawingo
Fri Sep 28, 2018 5:26 am
Forum: Questions & Answers
Topic: Passing Lists
Replies: 4
Views: 1496

Passing Lists

Is there a limitation in defining a RP in a Server Module? For Instance I want to create a reference to a List Object Define_Com Class(#PRIM_ACOL<#dwlg_do>) Name(#gUserList) Reference(*DYNAMIC) However i'm getting the error: "PRIM_ACOL<dwlg_DO> is only supported on the web." DWLG_DO Target Platform ...
by lawingo
Thu Aug 30, 2018 11:01 pm
Forum: Questions & Answers
Topic: I’d like to get some feedback / discussion going on these 2 questions …………….
Replies: 6
Views: 2241

Re: I’d like to get some feedback / discussion going on these 2 questions …………….

We don't have a mandatory of IE but some stuff we transmit with the bank has to be done through IE. Out of about 500 users we probably have 1/3 using Windows 7. "If it isn't broke, don't fix it!"
by lawingo
Thu Aug 30, 2018 10:58 pm
Forum: Questions & Answers
Topic: Sending mail from IBM I
Replies: 3
Views: 2343

Re: Sending mail from IBM I

I use the "SNDSMTPEMM" utility to send email from the AS400. I have a RP that builds a command string, for example: #W_CMD := 'SNDSMTPEMM RCP((' + #EMAILTO + ')) SUBJECT(' + "'" + #emailsbj + "'" + ') NOTE(' + "'" + #emailmsg + "'" + ') ATTACH((' + "'" + #EMAILRTNM + "'" + ' *PDF))' Exchange Fields(...
by lawingo
Fri Aug 10, 2018 5:59 am
Forum: Questions & Answers
Topic: Record to be updated has been changed error
Replies: 5
Views: 2003

Re: Record to be updated has been changed error

Is the Library List of the Imported File in the User Profile that is running the Web App? Just a thought.
by lawingo
Wed May 16, 2018 5:54 am
Forum: Questions & Answers
Topic: VLWeb SP2 Material Design and Dynamic PickLists
Replies: 3
Views: 1339

Re: VLWeb SP2 Material Design and Dynamic PickLists

I created mine a little backwards from how you said you did. I created a normal Reusable Part and attached it to the field. I created a Dynamic Picklist on the Field: Begin_Com Role(*EXTENDS #PRIM_OBJT) Begin_Com Role(*Visual #PRIM_EVEF) Name(#VisualEdit) Defaultvisual(True) Usepicklist(False) Compo...
by lawingo
Tue Mar 27, 2018 7:38 am
Forum: Questions & Answers
Topic: Email with Attachment
Replies: 5
Views: 1904

Re: Email with Attachment

Right or Wrong - Here is my working solution. I canned the Lansa Mail BIF (I got the attachment to work but it would send as garbage - I think there was some encoding issues) that I had previously put and I found this nifty utility on the iSeries called "SNDSMTPEMM" http://www-01.ibm.com/support/doc...
by lawingo
Tue Mar 27, 2018 4:41 am
Forum: Questions & Answers
Topic: IBM i Export / Import different EPC installed
Replies: 5
Views: 1733

Re: IBM i Export / Import different EPC installed

We run the same scenario. I had v14 in DEV and v12 in PRD for 6 months or so before I could update Production. When promoting I did have some version differences but nothing I couldn't remove and re-compile.
by lawingo
Tue Mar 27, 2018 4:38 am
Forum: Questions & Answers
Topic: Email with Attachment
Replies: 5
Views: 1904

Re: Email with Attachment

Job Log says "E-Mail message sent". It sends the email correctly - but without the attachment. Apparently after you execute the "MAIL_START" command if any of the following commands error out you have to re-issue the "MAIL_START" before executing the "MAIL_SEND" command otherwise it fails. I found t...
by lawingo
Tue Mar 27, 2018 2:31 am
Forum: Questions & Answers
Topic: Email with Attachment
Replies: 5
Views: 1904

Email with Attachment

I hope this is an easy solution. I want to send an email with attachment from the iSeries: Here's what I have #EMAILTO := 'lawingo@sherrillfurniture.com' #EMAILFROM := 'SMTP:lawingo@sherrillfurniture.com' #EMAILSBJ := 'Test Report' #EMAILMSG := 'tEST rEPORT' #EMAILRTNM := '/emaildocs/CHAD.PDF' It pa...
by lawingo
Tue Nov 21, 2017 7:55 am
Forum: Questions & Answers
Topic: Instance List Question
Replies: 5
Views: 1880

Re: Instance List Question

Perfect. Thanks for the tip.

Chad
by lawingo
Tue Nov 21, 2017 7:12 am
Forum: Questions & Answers
Topic: Instance List Question
Replies: 5
Views: 1880

Instance List Question

I have created my own Snap In Instance List. Everything works but the "Business Object Commands" associated to that Business Object do not appear. When I click on an item from the list, the commands tagged as "Instance Commands" show correctly - Like "Details" and "Notes". However, the commands tagg...
by lawingo
Thu Nov 09, 2017 1:35 am
Forum: Questions & Answers
Topic: Tiles & VLF
Replies: 2
Views: 1066

Tiles & VLF

Weird Issue. I have created a TILE object to show images to the user. My intention was to use this within my VLF on a COM Handler. However, when I click on the Tab that calls my Tile object the instance list go awol. The instance list turns black and becomes unusable. I can perform a search which re...
by lawingo
Tue Nov 07, 2017 6:09 am
Forum: Questions & Answers
Topic: compilation fail. as/400
Replies: 7
Views: 2933

Re: compilation fail. as/400

Have you checked your Library List of the user that is compiling the object? Does it include the library of the object you are trying to fetch data from? Just a thought.
by lawingo
Tue Nov 07, 2017 6:02 am
Forum: Questions & Answers
Topic: Crystal report 9.2 for Lansa Web
Replies: 3
Views: 1422

Re: Crystal report 9.2 for Lansa Web

Hello, I use Crystal XI for my regular VL apps. I can provide code and instructions if you are interested. For VL Web I use Crystal Reports Server. Basically you save the Report to the Reports server and then call the report and pass it parameters via a URL. Again, I can provide code & instructions ...