Search found 667 matches

by jyoung
Fri Nov 30, 2018 1:03 am
Forum: Questions & Answers
Topic: Async loading
Replies: 2
Views: 4939

Re: Async loading

The only way I know to do any kind of async work is with timers and then use an event to signal the work is completed. For example function options(*DIRECT) begin_com role(*EXTENDS #PRIM_OBJT) define_evt name(WorkCompleted) define_com class(#PRIM_TIMR) name(#Timer) Startup(Manual) Interval(100) mthr...
by jyoung
Wed Nov 28, 2018 5:50 am
Forum: Questions & Answers
Topic: iSeries Export/Import with IASP
Replies: 6
Views: 8204

Re: iSeries Export/Import with IASP

lol. Yeah they said the same thing here.

Jerry helped quite a lot in getting everything up and running. I gotta be missing something.

I put in a support ticket, so will update this thread when it gets figured out.
by jyoung
Wed Nov 28, 2018 5:20 am
Forum: Questions & Answers
Topic: iSeries Export/Import with IASP
Replies: 6
Views: 8204

Re: iSeries Export/Import with IASP

When I look at the import log it says the RP imported successfully. C EIM0268 Definition of component MGSAPPC02 successfully imported. However when I look in the IFS at /LANSA_dcxpgmlib/x_lansa/x_SYS/web/vl for that component in not there. Its also not /IASP1/LANSA_dcxpgmlib/x_lansa/x_SYS/web/vl whe...
by jyoung
Wed Nov 28, 2018 5:09 am
Forum: Questions & Answers
Topic: iSeries Export/Import with IASP
Replies: 6
Views: 8204

Re: iSeries Export/Import with IASP

Hey Art, When you import the save file, do you/where do you specify the IASP? I've tried an import with a small export, one RP and then do the import manually and still have the same issue. We've tested this before and I thought it worked, so it's all together possible I am missing something in crea...
by jyoung
Wed Nov 28, 2018 2:21 am
Forum: Questions & Answers
Topic: iSeries Export/Import with IASP
Replies: 6
Views: 8204

iSeries Export/Import with IASP

I get this may be better suited for support, but I thought I would try here too. We recently moved our servers to use an IASP and Support was super helpful in getting LANSA reconfigured correctly. I am having a bizarre issue that may or may not be related to the IASP. We do our deployments to Produc...
by jyoung
Thu Nov 15, 2018 1:55 am
Forum: Questions & Answers
Topic: A material design for read only fields
Replies: 2
Views: 2308

Re: A material design for read only fields

I had the same issue, I settled on two things. Mark the Field as "ReadOnly" Set the Appearance to "None" In this case I also hid the Helper Text by setting the HelperPosition to "None" Capture.PNG I don't know what the "offical" MD guidelines are, but for me, removing the under line removed the "ind...
by jyoung
Wed Nov 07, 2018 9:02 am
Forum: Questions & Answers
Topic: VLF-ONE "Sub" Command
Replies: 2
Views: 2186

Re: VLF-ONE "Sub" Command

Hmm. How did I miss that ... ?

That I think will solve a few issues I am running into. Will try it and get back to you.

Thanks!
Joe
by jyoung
Wed Nov 07, 2018 2:45 am
Forum: Questions & Answers
Topic: VLF-ONE "Sub" Command
Replies: 2
Views: 2186

VLF-ONE "Sub" Command

I am trying to figure out how to get this to work in VLF-ONE. I have an idea, but want to see if there is a better approach. I also feel like I have already asked this but for life of me I can't find it. If I have please forgive the incompetence. I have a business object that will have about 10 comm...
by jyoung
Thu Nov 01, 2018 12:50 am
Forum: Questions & Answers
Topic: Material Design Icon on Data Table List
Replies: 7
Views: 5246

Re: Material Design Icon on Data Table List

Hey Jan, Once again, there may be better way to handle this, but this seems to work. You are right, the problem, is that Part Columns do not have a click event, however the part itself does. This of course means we have to get a reference to the part. You do this by grabbing the part when the item g...
by jyoung
Wed Oct 31, 2018 12:11 am
Forum: Questions & Answers
Topic: VLF-ONE New Command
Replies: 5
Views: 2863

Re: VLF-ONE New Command

I thought I looked everywhere for that option and could not find it.

I did not think to check the command definitions themselves.

Thanks Mark!
by jyoung
Tue Oct 30, 2018 12:14 am
Forum: Questions & Answers
Topic: VLF-ONE New Command
Replies: 5
Views: 2863

Re: VLF-ONE New Command

Sure. Its attached as a zip files since you can't attach *.XML or *.TXT files. On a side note, it is possible to change the object type Id for the framework? The ID is VLFONE_DEMONSTRATION and its not a demo system its the main production framework. Feel like its having our production database named...
by jyoung
Sat Oct 27, 2018 7:01 am
Forum: Questions & Answers
Topic: VLF-ONE New Command
Replies: 5
Views: 2863

VLF-ONE New Command

I was testing out some new stuff in our VLF-ONE app and I noticed that a "New" button showed up in the menu. capture 1.PNG I don't recall seeing this before (although its altogether possible I have been over looking it) and we don't have any "New" command enabled at the "root" level. capture 2.PNG C...
by jyoung
Fri Oct 19, 2018 12:39 am
Forum: Questions & Answers
Topic: Material Design Icon on Data Table List
Replies: 7
Views: 5246

Re: Material Design Icon on Data Table List

Hey Jan, I do with a custom RP that implements the IListCellDesign. function options(*DIRECT) begin_com role(*EXTENDS #PRIM_PANL *implements #Prim_List.iListCellDesign) displayposition(1) left(0) tabposition(1) top(0) layoutmanager(#Layout1) define_com class(#PRIM_TBLO) name(#Layout1) define_com cla...
by jyoung
Fri Oct 19, 2018 12:31 am
Forum: Questions & Answers
Topic: VLF-ONE Script Error on Debug with Breakpoint
Replies: 3
Views: 1899

Re: VLF-ONE Script Error on Debug with Breakpoint

Hey Danny, Through logs of logging / tracing and process of elimination :), I figured out what is going on. https://forum.developer.lansa.com/viewtopic.php?f=3&t=1925 Regarding the debugging crash, it sounds like ya'll are aware of the issue. Thought it was some bizarre thing I was doing, which is a...
by jyoung
Thu Oct 18, 2018 6:36 am
Forum: Questions & Answers
Topic: PRIM_MD.Dropdown Changed
Replies: 3
Views: 4719

PRIM_MD.Dropdown Changed

The "Changed" event on most PRIM_MD.* controls gets fired when the USER changes the value of the field. This does not seem to be the case with PRIM_MD.DropDown as the Changed event gets fired when the value is set. This is causing all kinds of havoc with change detection. I have a field that uses a ...
by jyoung
Thu Oct 18, 2018 4:37 am
Forum: Questions & Answers
Topic: VLF-ONE Script Error on Debug with Breakpoint
Replies: 3
Views: 1899

VLF-ONE Script Error on Debug with Breakpoint

I am trying to debug a complex eventing problem but I keep getting a script error. Capture.PNG I have a "base" command handler extends #VF_AC010O and collects up all the controls on the window and signals a "FieldChanged" event when one of those controls change. The error references line 143, which ...
by jyoung
Tue Oct 16, 2018 2:39 am
Forum: Suggestions for Product Enhancements
Topic: Repository File Changed Indicator
Replies: 0
Views: 14226

Repository File Changed Indicator

It would be really nice to have a "file changed" indicator in the Repository List. For example, looking at this list you would not think that anything has changed and needs to be recompiled. Capture1.PNG But something has! It shows in the "Open Objects" tool window. Capture2.PNG I can't tell you how...
by jyoung
Sat Oct 13, 2018 7:30 am
Forum: Questions & Answers
Topic: Publishing Web Services
Replies: 14
Views: 10325

Re: Publishing Web Services

Hey Pablo, Yeah the DLL is there (have the wrong one highlighted, but you can see the _94 one) Capture2.PNG I my other test LANSA loaded the module just fine and I can execute the normal server routines with it. Its when I try to access the API routine through a standard request (browser, postman et...
by jyoung
Sat Oct 13, 2018 2:11 am
Forum: Questions & Answers
Topic: Publishing Web Services
Replies: 14
Views: 10325

Re: Publishing Web Services

Hi Pablo, Having an interesting problem. I keep getting an error {"error":{"messages":["X_COMP returned error code 22. Check X_ERR.LOG for more information."]}} The fact that I am getting JSON back tells me something is working. Checking the Error Log I find Fri Oct 12 09:56:48 2018 Version 14.2.0 B...
by jyoung
Fri Oct 12, 2018 8:43 am
Forum: Questions & Answers
Topic: Publishing Web Services
Replies: 14
Views: 10325

Re: Publishing Web Services

Hey Pablo,

Thanks for that, I will dig into it.

Any word on whether or not it will be available on the iSeries?

Many Thanks,
Joe