Search found 687 matches

by jyoung
Sat Jan 07, 2017 4:55 am
Forum: Questions & Answers
Topic: Editing source and Layouts disappearing
Replies: 8
Views: 2792

Re: Editing source and Layouts disappearing

Hi Art, Are you saying the entire layout is being deleted? I seem to recall having the same issue a few weeks ago as I was CONSTANTLY re-creating my layouts. I have found that if I delete the component in the designer then it is going to actually remove that component from the source which will hose...
by jyoung
Sat Jan 07, 2017 4:38 am
Forum: Questions & Answers
Topic: Images no longer being found after check in
Replies: 3
Views: 1847

Images no longer being found after check in

I had added a few more images to my Repository and instead of just checking those new images in, I mistakenly checked in ALL images. Now, some of the images that have been working on our development iSeries are no longer working. The http request is returning 404. Capture.PNG I thought perhaps they ...
by jyoung
Fri Jan 06, 2017 2:49 am
Forum: Questions & Answers
Topic: iPad Keyboard and List Controls
Replies: 5
Views: 2130

Re: iPad Keyboard and List Controls

Experiencing the same behavior in a DropDownList.
The DropDownStyle is DropDownList so no edits should be allowed.

Setting it to ReadOnly does not work.
by jyoung
Fri Jan 06, 2017 1:33 am
Forum: Questions & Answers
Topic: Dates and DateTime Pickers
Replies: 2
Views: 1599

Re: Dates and DateTime Pickers

Using STD_DATEX instead of the control solved the problem nicely.

Thanks!
Joe
by jyoung
Fri Jan 06, 2017 1:20 am
Forum: Questions & Answers
Topic: Error Logs from ServerModules
Replies: 6
Views: 2824

Re: Error Logs from ServerModules

Come to find out I don't have access to that folder. I got the dialog like you mentioned (wish I would have screen shot it) but after I hit Ok (or something I don't recall what it was) I can run the command again and get access to the folder. Running the divide by zero routine and I get the error in...
by jyoung
Thu Jan 05, 2017 4:50 am
Forum: Questions & Answers
Topic: Dates and DateTime Pickers
Replies: 2
Views: 1599

Dates and DateTime Pickers

I have a date in signed(8) field with the value of 20160410. I can convert that field (#WSDWP) to a #STD_DATEX with #STD_DATEX := #WSDWP.AsDate( CCYYMMDD ) Displaying the date on a label works great with #WeekLabel := #STD_DATEX.AsDisplayString( MMsDDsCCYY ) However, when I put that date into a Date...
by jyoung
Wed Jan 04, 2017 9:52 am
Forum: Questions & Answers
Topic: Thoughts on Task Tracking
Replies: 10
Views: 3746

Re: Thoughts on Task Tracking

At my last job we had a VCS setup with Git. We used it with quite a bit of success once we got it figured out. Really only had one minor issue it which I think was due to how we where handling what gets in and out of the working folder. At my new job we don't have a VCS option. (Yet) :D I would grea...
by jyoung
Wed Jan 04, 2017 7:21 am
Forum: Questions & Answers
Topic: Thoughts on Task Tracking
Replies: 10
Views: 3746

Thoughts on Task Tracking

I am curious if anyone is using Task Tracking and what your thoughts are on it? Pretty much all the work I have done so far as been solo, but we are wanting to get the rest of the team involved pretty soon. We use Gemini to track our work, so while I think the Full approach would work, the admin ove...
by jyoung
Wed Jan 04, 2017 1:34 am
Forum: Questions & Answers
Topic: iPad Keyboard and List Controls
Replies: 5
Views: 2130

Re: iPad Keyboard and List Controls

There are two ReadOnly settings for a List Column.
ColumnReadOnly and ReadOnly.

ColumnReadOnly was already checked, ReadOnly was not.

Checking ReadOnly solved the issue.
by jyoung
Wed Jan 04, 2017 1:18 am
Forum: Questions & Answers
Topic: Error Logs from ServerModules
Replies: 6
Views: 2824

Re: Error Logs from ServerModules

That's the problem, I am not getting any of those logs.

The problem turned out to be a error in the select_sql command.

I tried a divide by zero error to see if I get the log and I don't.
error.png
error.png (12.42 KiB) Viewed 2623 times
Web Server Log
log1.png
log1.png (14.91 KiB) Viewed 2623 times
Data Server Log
log2.png
log2.png (18.02 KiB) Viewed 2623 times
by jyoung
Wed Jan 04, 2017 1:07 am
Forum: Questions & Answers
Topic: iPad Keyboard and List Controls
Replies: 5
Views: 2130

Re: iPad Keyboard and List Controls

We have 14.1.0 (build 4138).
Did not know about the ColumnReadonly setting. Will try that and get back to you.
by jyoung
Fri Dec 30, 2016 7:21 am
Forum: Questions & Answers
Topic: iPad Keyboard and List Controls
Replies: 5
Views: 2130

iPad Keyboard and List Controls

We are targeting mobile devices, specifically iPads and iPhones for our web app. One of the odd behaviors we are experiencing is that whenever a list item is clicked the device keyboard opens. There is no text to enter or anything that would require a keyboard, we just intercept the ItemClick event ...
by jyoung
Thu Dec 29, 2016 9:38 am
Forum: Questions & Answers
Topic: Object Inheritance and Data Loading
Replies: 2
Views: 1411

Re: Object Inheritance and Data Loading

I was afraid of that, but as you said, at least its consistent.

Thanks for the help.
by jyoung
Thu Dec 29, 2016 7:53 am
Forum: Questions & Answers
Topic: Object Inheritance and Data Loading
Replies: 2
Views: 1411

Object Inheritance and Data Loading

I have to Reusable Part Objects, MOBClient and MOBClientStatistic. MOBClientStatistic inherits from MOBClient. function options(*DIRECT) begin_com role(*EXTENDS #PRIM_OBJT *LISTFIELDS #ListFields) defaultpty(Caption) group_by name(#ListFields) fields(#CLOFID #CLOCN #CLOFN #CLOD) define_pty name(Offi...
by jyoung
Thu Dec 29, 2016 4:23 am
Forum: Questions & Answers
Topic: Error Logs from ServerModules
Replies: 6
Views: 2824

Re: Error Logs from ServerModules

This is happening on my local dev box, so its Windows.
by jyoung
Wed Dec 28, 2016 3:07 am
Forum: Questions & Answers
Topic: Error Logs from ServerModules
Replies: 6
Views: 2824

Error Logs from ServerModules

Sometimes my ServerModule crashes with a Fatal Error and I get the "Unrecoverable error occurred while executing the Web application routine" message. Capture.PNG When I look for the error logs under local or web (both data and webserver) I don't have any log entries. Should these errors be logged? ...
by jyoung
Thu Dec 22, 2016 3:34 am
Forum: Questions & Answers
Topic: Working With Multiple Layouts
Replies: 5
Views: 2552

Re: Working With Multiple Layouts

By move controls to the layout items, I am referring to dragging the controls / resuable parts from the repository or controls menu unto the designer to a specific row / column location. Apologies for being dense, but I want to make sure I am understanding what you are saying. If I have two layouts,...
by jyoung
Thu Dec 22, 2016 1:36 am
Forum: Questions & Answers
Topic: Working With Multiple Layouts
Replies: 5
Views: 2552

Re: Working With Multiple Layouts

Hi Stewart, The StatsPanel and the ChartPanel are NOT reusable parts, just two panels, one with some stats the other with a bar chart. The WideLayout shows these panels side by side in a horizontal fashion whereas the NarrowLayout shows these panels stacked (stats on top of chart) in a vertical fash...
by jyoung
Wed Dec 21, 2016 8:39 am
Forum: Questions & Answers
Topic: How to determine if a Widget is loaded
Replies: 3
Views: 1552

Re: How to determine if a Widget is loaded

Thanks for the info on the widget. I ended up creating a timer to handle it. First thing I do is define a field to hold whether or not the widget is initialized and capture it in the Initialized event define field(#ChartInitialized) type(*BOOLEAN) default(False) evtroutine handling(#MOBBarChart.Init...
by jyoung
Wed Dec 21, 2016 7:53 am
Forum: Questions & Answers
Topic: How to determine if a Widget is loaded
Replies: 3
Views: 1552

How to determine if a Widget is loaded

I have a widget that renders a Google bar chart. After I get some data from the ServerModule, I push that data into the widget to display the chart. Locally this all works great. When I deployed it to our development IBM i server however, I get fatal error that states Can't access a widget before it...