Page 1 of 1

LANSA integrator WSDL

Posted: Thu Jun 23, 2016 1:36 am
by JASLANSA
Hi all I have a wsdl from a third party that fails when I try to use it in LANSA

I have tried to add it as a URL when created the solution – it fails with error 401 ( the site is password protected and there is no option to add an ID Password in integrator
I have tried downloading the WSDL and pointing to the local copy – this fails with an import error for the same reason it tried to import from the https site and fails

Note this can be loaded into composer OK - this allows an ID and password

Any thought on how I can overcome this ?

Re: LANSA integrator WSDL

Posted: Thu Jun 23, 2016 5:33 pm
by ahj_dk
Last I had the same issue I got a 3. party tool to merge the wsdl into one wsdl, I can't remember what tool I used but maybe this can help: http://wcfextras.codeplex.com/

I think I did something like downloading all the imported files to a local webserver without auth, but Integrator did not load the wsdl from the imports, therefore I looked into merging all the wsdl's

Re: LANSA integrator WSDL

Posted: Fri Jun 24, 2016 10:02 am
by Deepak
Can you please run this by the LANSA Support team in your Region? They will be able to investigate further.