VL Web - #prim_var not supported on the web

This Q&A forum allows users to post and respond to "How Do I Do ....." questions. Please do not use to report (suspected) errors - you must use your regional help desk for this. The information contained in this forum has not been validated by LANSA and, as such, LANSA cannot guarantee the accuracy of the information.
Post Reply
davidbalansa
Posts: 47
Joined: Mon Feb 01, 2016 10:08 am
Location: Australia

VL Web - #prim_var not supported on the web

Post by davidbalansa » Thu Jun 23, 2016 10:07 pm

Hi,

I attempted to use the #prim_var class in a reusable part with a target platform 'Web Browser'. I get the message 'PRIM_VAR is not supported on the Web'.

Will this be implemented in the future or is this a limitation of the Web platform?

Regards,
David Balazic

User avatar
Stewart Marshall
Posts: 417
Joined: Thu Nov 05, 2015 5:25 pm

Re: VL Web - #prim_var not supported on the web

Post by Stewart Marshall » Fri Jun 24, 2016 9:08 am

Hi David

We have no specific plans as to today.

Do you have a particular reason for needing a variant?

Regards
Stewart Marshall

Independent IT Consultant
www.marshallfloyd.com.au

davidbalansa
Posts: 47
Joined: Mon Feb 01, 2016 10:08 am
Location: Australia

Re: VL Web - #prim_var not supported on the web

Post by davidbalansa » Fri Jun 24, 2016 12:05 pm

Hi Stewart,

Thank you for the response.

I was attempting to design a generic base component that could return a code which could be either alpha or numeric based on derived object. So I thought I would give #prim_var a try. When I saw the message I was interested why. It is a non issue as there are a number of ways I can implement the solution.

Thanks again.
Regards,
David Balazic

Post Reply