Space offset error message Integrator

This Q&A forum allows users to post and respond to "How Do I Do ....." questions. Please do not use to report (suspected) errors - you must use your regional help desk for this. The information contained in this forum has not been validated by LANSA and, as such, LANSA cannot guarantee the accuracy of the information.
Post Reply
René Houba
Posts: 61
Joined: Thu Nov 26, 2015 7:03 am

Space offset error message Integrator

Post by René Houba » Wed Mar 08, 2017 12:14 am

An application that makes heavy use of JSM on the iSeries, randomly gives an error message like below.
Is someone familiair with an error message like that?

Message ID . . . . . . : MCH0601 Severity . . . . . . . : 40
Message type . . . . . : Diagnostic
Date sent . . . . . . : 07.03.17 Time sent . . . . . . : 13:12:45

Message . . . . : Space offset X'00569000' or X'0000000000000000' is outside
current limit for object QPADEV0004QSECOFR 637304.
Cause . . . . . : A program tried to set a space pointer, tried to use
storage outside a space, or tried to use an unallocated page in teraspace.
The space class is X'04'. The space class designates the type of space:
00-primary associated space (includes space objects).
01-secondary associated space 0.
02-implicit process space for automatic storage.
03-implicit process space for static storage in activation group mark
04-implicit process space for heap identifier X'00000000' in activation
group mark X'0000000000000000'.
05-constant space.
06-space for handle-based heap identifier X'00000000'.
07-teraspace offset X'0000000000000000'.
08-teraspace for System i5 PASE memory address X'0000000000000000'.
Offset X'00569000' only applies to storage outside teraspace.
X'8000000000000000C6DB4F4503001000' is a pointer to the teraspace page or
the start of the implicit process space for the allocation.

Post Reply