Page 1 of 1

VLF-ONE Error after EPC141017

Posted: Fri Apr 07, 2017 8:42 pm
by kno_dk
Hi

I have (had) a running VLF-ONE application. but last week I installed epc 141017 on my server and dev. pc. I have compiled my version of UF_OEXEC and
checked it in. I have made the steps as described in the EPC installation guide.
When I run the VLF-ONE application I get this message:
Fatal Error:

Reusable Part VF_AC006O is compiled on a later version of LANSA than is currenly used by the main page. Recompile the main page as well.
Reported By:

http://xx.xx.xx.xx:4039/DCXPGMLIB/lansa ... sa_base.js, line 12


What am i missing? Is there something else it need to check in?

/Klaus

Re: VLF-ONE Error after EPC141017

Posted: Sat Apr 08, 2017 8:25 am
by MarkD
Release notes, instructions and prerequisites are here - http://docs.lansa.com/14/en/lansa048/in ... 8_6850.htm

Are the LANSA/VL systems on your PC and IBM i server both at EPC141011 level (or later)?

I think if they were the folder in the message be lansa_14_1_11_2 instead of lansa_14_1_1_0.

Re: VLF-ONE Error after EPC141017

Posted: Mon Apr 10, 2017 5:05 am
by kno_dk
Hi.

both pc and server are at EPC141011 and EPC141017. I have followed the installation description with out any problem.

Re: VLF-ONE Error after EPC141017

Posted: Mon Apr 10, 2017 8:58 am
by MarkD
In your VL folder like C:\Program Files (x86)\<LANSA_SYSTEM>X_WIN95\X_LANSA\web\vl what folders do you have, and what does file vlweb.dat contain?
Capture3.JPG
Capture3.JPG (21.18 KiB) Viewed 3355 times

Re: VLF-ONE Error after EPC141017

Posted: Mon Apr 10, 2017 9:01 am
by MarkD
Also could you locate the newly recompiled EOI_OEXEC.html file and post it to the forum?

Re: VLF-ONE Error after EPC141017

Posted: Mon Apr 10, 2017 4:35 pm
by kno_dk
vlwweb.dat: lansa_14_1_1_0

I do not have the folder lansa_14_1_11_2

And here are the code:
<!DOCTYPE html>
<html lang="en" style="height:100%">
<head>
<meta charset="utf-8" />
<meta name="mobile-web-app-capable" content="yes">
<meta name="apple-mobile-web-app-capable" content="yes">
<meta name="apple-touch-fullscreen" content="yes">
<meta name="viewport" content="width=device-width, initial-scale=1, minimum-scale=1">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
</head>
<body style="height:100%; margin-left:0px;margin-right:0px;margin-top:0px;margin-bottom:0px">
<script src="/%{lansa_webalias}%/lansa_14_1_1_0/lansa.js"></script>
<script>
(function(LANSA){
if(!LANSA){document.write("Failed to load /%{lansa_webalias}%/lansa_14_1_1_0/lansa.js");return}
LANSA.init({part:"%{lansa_partition}%",sys:"%{lansa_webalias}%",ver:"030659760",lang:{def:"DAN",code:{"DAN":"da","ENG":"en"}},splash:{limg:"spin",mtxt:{"ENG":"Loading"}}});%{lansa_webroutine_output}%
LANSA.showPage("EOI_OEXEC");
}(window["LANSA"]))
</script>
<noscript>This page requires JavaScript.</noscript>
</body>
</html>

So i do not have the newest JS code?

Should I try to install the epc's again? both 141011 and 141017?

Re: VLF-ONE Error after EPC141017

Posted: Mon Apr 10, 2017 4:40 pm
by MarkD
It looks like EPC141011 did not install correctly.
I would reapply EPC141011 to your VL-IDE to start.
Then check the folders again and vlwweb.dat content again.

Re: VLF-ONE Error after EPC141017

Posted: Mon Apr 10, 2017 5:15 pm
by kno_dk
I have now installed EPC 141011 and I have the folder and the VLF-one works again. Thanks.

I will try to install epc 141017 and see if that will work also.

Re: VLF-ONE Error after EPC141017

Posted: Mon Apr 10, 2017 5:17 pm
by MarkD
I think you EPC141017 installed okay already - that's why you are getting the error message.
Just recompile your entry point form and see if it starts up okay now.

Re: VLF-ONE Error after EPC141017

Posted: Mon Apr 10, 2017 5:28 pm
by kno_dk
I have compile the entry point and it works fine.