LANSA web - V12 vs V14

This Q&A forum allows users to post and respond to "How Do I Do ....." questions. Please do not use to report (suspected) errors - you must use your regional help desk for this. The information contained in this forum has not been validated by LANSA and, as such, LANSA cannot guarantee the accuracy of the information.
Post Reply
kno_dk
Posts: 89
Joined: Tue Feb 23, 2016 12:00 am

LANSA web - V12 vs V14

Post by kno_dk » Mon Jun 12, 2017 10:23 pm

I have a WEB application which is a mix of old webevent and wam. The application is using frames - so I have a header, navi, main and footer. In header I have a drop down which controles what to search for. When the user hit the search icon, it sends the values to the other frames in a javascrip. It works great on LANSA V12. But in LANSA V14 I do not get anything into the fields in my wam running in the main frame.

I have looked at the data it sent to the server (In chrome and F12 ) - and it was the same which was sent to the server. I have used fiddler to see what will be sent to the server and that was the same. I have add the logic to the wam where I put the variables into a trace file on the server. The variables are empty.
The applications should be the same but on 2 different LANSA versions.

I think there have been some changes in LANSA web on how to handle variables.

Is there anybody who have had the same issue?
Is there anybody who can tell me how to dump the input before it reach the LANSA programs.

/Klaus

Post Reply