Page 1 of 1

VLF-ONE Merging Frameworks

Posted: Tue Jul 17, 2018 2:58 am
by jyoung
In our VLF-ONE workflow, we create a copy of the framework that gets worked on, then when its complete it gets merged into the "master" framework file.

This has been working out really well, until now at least. All of our merges up until now, have been new objects going into an EXISTING application.

Now, we have a new Application, with new Objects that need to get merged and I am running into issues.

Here is what our merge looks like
merge list.PNG
merge list.PNG (51.85 KiB) Viewed 5713 times
As you can see we have one new Application (Associates) with 3 new Objects (Search, Check History, Check Detail). The merge tool automatically added the additional commands (that have yet to be done).

The problem is that when I import the Application by itself, I get an error about the missing Objects.
merge error.PNG
merge error.PNG (19.78 KiB) Viewed 5713 times
When I merge the Objects I cannot choose the Application to merge them into. It only lists the two existing Applications.
merge missing application.PNG
merge missing application.PNG (51.2 KiB) Viewed 5713 times
It seems like a catch 22, I can't import the Application without the Objects, yet I cannot import the Objects without the Application.

Doing them all at once does not help either, as it will import the Application but STILL PROMPT for the parent of the Objects and the just imported Application does not appear in the selection list.

How do I get this merge done?

- Joe

Re: VLF-ONE Merging Frameworks

Posted: Tue Jul 17, 2018 9:12 am
by MarkDale
How about

1. remove everything (VF_FP008s) from the Merge List except VF_FP002 (Associates)

2. remove everything from the reference list

3. merge the application, save and re start the framework

4. do the merge again - the new application is now an option for the parent of the new business objects

Note - the VF_FP008 objects are link objects between Application objects (VF_FP002) and Business objects (VF_FP003).
So the merge tool was objecting when you were trying to merge them in without the business objects they linked to.

Re: VLF-ONE Merging Frameworks

Posted: Wed Jul 18, 2018 12:12 am
by jyoung
That worked, sort of.

Now I have multiple objects listed
mulitple objects.PNG
mulitple objects.PNG (78.49 KiB) Viewed 5680 times
Deleting 1 deletes both.

Had to do the merge multiple times.

First to get the application in, then to get the objects in. After that, when I ran the app, I got a numerous errors.
errors.png
errors.png (24.4 KiB) Viewed 5680 times
Have to say, that message does not help much. I have to to go through each command to find what command is identified by that guid. The workbench should at least have a search to find commands by identifier.

After not having any success and giving up in frustration, I did the merge a third time. This made the errors go away, but I still have duplicate objects in my workbench.

Re: VLF-ONE Merging Frameworks

Posted: Wed Jul 18, 2018 12:50 am
by atostaine
Dear God the Merge Tool. :o Good luck. :D

Re: VLF-ONE Merging Frameworks

Posted: Wed Jul 18, 2018 4:14 am
by jyoung
I admit it, I punted.

Could not take it anymore, so I just manually added the App, Commands and Objects in the target framework.

Re: VLF-ONE Merging Frameworks

Posted: Wed Jul 18, 2018 3:14 pm
by MarkD
If you mess up a merge (or a merge messes you up) it’s worth remembering that every version of your framework should have been saved in a subfolder VF_Versions_ of your partition execute folder e.g. C:\Program Files (x86)\LANSA\X_WIN95\X_LANSA\x_dem\execute\VF_Versions_

Sometimes, rather than trying to ‘repair’ a messed up framework version you might do better by starting over with the last saved good version from the VF_Versions_ folder before attempting the operation again.

Re: VLF-ONE Merging Frameworks

Posted: Sat Mar 16, 2019 3:01 am
by jyoung
This bit me in the behind yet again.
This happens after using the MergeTool.
Capture.PNG
Capture.PNG (19.5 KiB) Viewed 4551 times
I added the Application (without the Objects) to avoid the previously mentioned issues. Then added the Objects to the newly created Application.

Initially everything looked ok, until a coworker checked it out and saw that the objects where duped.

Whats really interesting, is that each duplicated objects SHARES THE SAME Internal and Unique Identifier.
For example, check out these two captures. Two different objects selected, but they have the same identifiers.
Capture1.PNG
Capture1.PNG (54.19 KiB) Viewed 4551 times
Capture2.PNG
Capture2.PNG (55.61 KiB) Viewed 4551 times
EDIT
I'm working up an example to send to to support.

Re: VLF-ONE Merging Frameworks

Posted: Sat Mar 16, 2019 4:34 pm
by Balaji
Hello jyoung,

Hope this will help you.

Follow this sequence,

1. Add all commands list first .
2. business objects.
3. Save framework (new command list and the business object will visible after restart framework.restart framework is optional)
5. Now add Applications.
6. Save and restart framework.

Now you able to see a single business object.

Regards,
Balaji

Re: VLF-ONE Merging Frameworks

Posted: Tue Mar 19, 2019 3:29 am
by jyoung
Hey Balaji,

By Commands, you mean new command definitions right? Not Command Handlers / Filters.

In this case, all the command are already in the framework ( the handlers are not).

When I try to merge JUST the Business Objects BEFORE the Application, the Merge Tool does not know what their parent is and asks where to put them.
objects.PNG
objects.PNG (55.63 KiB) Viewed 4517 times
Since the Application does not exist, where do they go?

Thanks,
Joe

Re: VLF-ONE Merging Frameworks

Posted: Thu Mar 21, 2019 6:00 pm
by Balaji
Hello jyoung ,

Yes, new Or Modified command definitions.

Business Objects will be created in the framework.

The application already contains link of Business Objects which is mapped.

Hope so this will help you.

Kindly let me know if need any further information.

Regards,
Balaji