V14SP1 WAM: Query string format when receiving parameters from other sites.

This Q&A forum allows users to post and respond to "How Do I Do ....." questions. Please do not use to report (suspected) errors - you must use your regional help desk for this. The information contained in this forum has not been validated by LANSA and, as such, LANSA cannot guarantee the accuracy of the information.
Post Reply
Rieko Saitoh
Posts: 32
Joined: Sat Apr 30, 2016 11:46 am

V14SP1 WAM: Query string format when receiving parameters from other sites.

Post by Rieko Saitoh » Fri Aug 10, 2018 12:59 pm

Hi,

product: WAM
LANSA version: V14SP1

<background>
WAM's Webroutine is called with GET from other site. Other site requests with GET parameters.

<details>
When WAM program receives parameter values ​from other site, we have to write in the query string as follows.
f(field ID) = value
ex.) f(STD_TEXT) = '111'

However, in general, the query string is written as follows.
Parameter name = value
ex.) STD_TEXT = '111'

Currently, it is described as (1) below. However, I would like to write like (2) to receive GET parameters. On other sites, it is difficult to make a GET request in the form of "f(field ID) = value".
(1) https://domain/cgi-bin/lansaweb?wam=TESTWAM&webrtn=wr_Test&ml=LANSA:XHTML&part=tst&lang=JPN&f(STD_TEXT)='111'
(2) https://domain/cgi-bin/lansaweb?wam=TESTWAM&webrtn=wr_Test&ml=LANSA:XHTML&part=tst&lang=JPN&STD_TEXT='111'

Does anyone know how to receive parameters in the form of (2)?

Thank you.

Best regards,
Rieko Saitoh
LANSA japan

AbelS
Posts: 24
Joined: Wed Nov 16, 2016 1:43 pm
Location: Sydney, Australia
Contact:

Re: V14SP1 WAM: Query string format when receiving parameters from other sites.

Post by AbelS » Fri Aug 10, 2018 3:19 pm

See the second last post for this issue: viewtopic.php?f=3&t=1837

WAMs don't support your desired format. Imagine a user has a field name "LANG". It would clash with the WAM's language parameter.

HTH

Rieko Saitoh
Posts: 32
Joined: Sat Apr 30, 2016 11:46 am

Re: V14SP1 WAM: Query string format when receiving parameters from other sites.

Post by Rieko Saitoh » Tue Aug 14, 2018 2:30 pm

Hi,

Thank you very much for your reply. I could understand why it is not supported.
Thank you for your support.

Best regards,
Rieko Saitoh
LANSA japan

Post Reply