LANSA Integrator

This Q&A forum allows users to post and respond to "How Do I Do ....." questions. Please do not use to report (suspected) errors - you must use your regional help desk for this. The information contained in this forum has not been validated by LANSA and, as such, LANSA cannot guarantee the accuracy of the information.
Post Reply
kno_dk
Posts: 88
Joined: Tue Feb 23, 2016 12:00 am

LANSA Integrator

Post by kno_dk » Fri Aug 24, 2018 9:02 pm

Hi.

I have moved (save/restore entire system) a system to another server (IBM I), changed some network setup so it fits in the new enviroment, and now I am testing the system.

we use a lot of external web-services. We use Lansa Integrator to access these web-services. But on this new set up I can not get access to the web-services. I have talked to those responsible to the web-services and they say they can se the request but I do not get any response back.

Below you can see the SOAP_fault.xml i get. does anybody have a hint of what the problem is and where to look at it? is a network problem on the IBM I, Firewall og setup of integrator?

Thanks

/Klaus

<?xml version="1.0" encoding="UTF-8"?>

-<soapenv:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">


-<soapenv:Body>


-<soapenv:Fault>

<faultcode>soapenv:Server.userException</faultcode>

<faultstring>java.lang.NullPointerException</faultstring>


-<detail>

<ns1:stackTrace xmlns:ns1="http://xml.apache.org/axis/">java.lang. ... xceptionat org.apache.axis.wsa.UUIDGenerator.getUUID(UUIDGenerator.java:58)at org.apache.axis.wsa.MIHeader.<init>(MIHeader.java:74)at org.apache.axis.wsa.WSAHandler.processClientResponse(WSAHandler.java:80)at org.apache.axis.wsa.WSAHandler.invoke(WSAHandler.java:41)at org.apache.axis.client.AxisClient.invokeTransport(AxisClient.java:154)at org.apache.axis.client.AxisClient.invoke(AxisClient.java:289)at org.apache.axis.client.Call.invokeEngine(Call.java:2838)at org.apache.axis.client.Call.invoke(Call.java:2824)at org.apache.axis.client.Call.invoke(Call.java:2501)at org.apache.axis.client.Call.invoke(Call.java:2424)at org.apache.axis.client.Call.invoke(Call.java:1835)at com.XXX.XXX.order._10.SI_Order_Sync_OutBindingStub.SALESORDER_SIMULATE(SI_Order_Sync_OutBindingStub.java:1297)at com.acme.service.soap.SalesorderSAPVersion3Service.callOperation_SALESORDER_SIMULATE(SalesorderSAPVersion3Service.java:272)at sun.reflect.GeneratedMethodAccessor150.invoke(Unknown Source)at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)at java.lang.reflect.Method.invoke(Method.java:508)at com.lansa.jsm.service.SOAPAgentService.else(Unknown Source)at com.lansa.jsm.service.SOAPAgentService.for(Unknown Source)at com.lansa.jsm.service.SOAPAgentService.command(Unknown Source)at com.lansa.jsm.g.do(Unknown Source)at com.lansa.jsm.g.do(Unknown Source)at com.lansa.jsm.g.run(Unknown Source) </ns1:stackTrace>

<ns2:hostname xmlns:ns2="http://xml.apache.org/axis/">127.0.0.1</ns2:hostname>

</detail>

</soapenv:Fault>

</soapenv:Body>

</soapenv:Envelope>

bark
Posts: 24
Joined: Thu Jan 05, 2017 9:56 am

Re: LANSA Integrator

Post by bark » Mon Aug 27, 2018 5:14 pm

Try to remove the SOAPAgent from the problem and to focus on the HTTP TCP/IP connection.
Use the HTTPService to make either:
a GET request to http://www.webservicex.net/stockquote.asmx
or a POST request using some SOAP XML.
This would tell you if it was a network issue.

kno_dk
Posts: 88
Joined: Tue Feb 23, 2016 12:00 am

Re: LANSA Integrator

Post by kno_dk » Mon Aug 27, 2018 6:17 pm

Hi.

Found the error.

I had changed the domain name in the command CHGTCPDMN but in the host table it was not changed with the new domain name. Removed the old and type in the new and then it worked.
/Klaus

Post Reply