Page 1 of 1

Import Tables From IBM i

Posted: Thu Nov 29, 2018 12:10 pm
by nic.hall
The' Import Tables From IBM i' is creating fields with suffixes for fields that already exist in the repository with the same attributes. In one case where the field does not exist a suffix is being added. Is there a way to stop this from happening?

Re: Import Tables From IBM i

Posted: Thu Nov 29, 2018 2:14 pm
by KevinW
Are you absolutely certain that the fields are the same in absolutely every way as when they were originally created via "Import Tables From IBM i"? Is it possible that the 3rd party (or you) has made a change that is not shown in LANSA? Do you have the previous version of the Other files to compare?

Re: Import Tables From IBM i

Posted: Fri Nov 30, 2018 2:02 am
by atostaine
The suffix's are very annoying, but I've never seen it make a mistake. I wish the import function alerted to duplicate field names before I import so I can resolve.

Art

Re: Import Tables From IBM i

Posted: Fri Dec 07, 2018 2:51 am
by nic.hall
Deleted the other file and all fields that start with OH from the repository and reloaded the file. The import is still adding a suffix.
Capture.PNG
Capture.PNG (172.56 KiB) Viewed 3638 times

Re: Import Tables From IBM i

Posted: Fri Dec 07, 2018 2:57 am
by atostaine
Are you sure they are deleted from the repository? If you are using a slave install they also have to be deleted from the master repository.

Re: Import Tables From IBM i

Posted: Fri Dec 07, 2018 3:05 am
by caseywhite
Art, if you click on the preview button (magnifying glass) in the popup after you click load but before you click save, it will show you if there are any 001, 002, etc. suffixes. At that point you can resolve and reload once things are resolved.

Re: Import Tables From IBM i

Posted: Fri Dec 07, 2018 3:21 am
by nic.hall
There are no OH* fields on the master.
Capture.PNG
Capture.PNG (29.94 KiB) Viewed 3635 times

Re: Import Tables From IBM i

Posted: Fri Dec 07, 2018 3:42 am
by caseywhite
Check for WAM, Reusable Parts, Web pages, etc. It matches on ID across the entire IDE.

Re: Import Tables From IBM i

Posted: Fri Dec 07, 2018 7:49 am
by atostaine
caseywhite wrote:
Fri Dec 07, 2018 3:05 am
Art, if you click on the preview button (magnifying glass) in the popup after you click load but before you click save, it will show you if there are any 001, 002, etc. suffixes. At that point you can resolve and reload once things are resolved.
OH boy. It's been awhile since I imported one. I'm happy.

Re: Import Tables From IBM i

Posted: Sat Dec 08, 2018 6:13 am
by nic.hall
This problem was "corrected" by deleting the partition in VL. After recreating the partition the suffix is not being added to the field names.