Page 1 of 1

Scheduling thru Windows Task Scheduler

Posted: Tue Apr 16, 2019 10:24 pm
by lawingo
We transfer data from our iSeries to a Windows Server that is used for a Dealer Portal. The transfer happens about 4:30 am and is automated through Windows Task Scheduler. Up until about a month ago everything worked (nothing changed, unless maybe a Windows Update?). Now the Scheduled Job fires and an X-Run is created but nothing happens. The program doesn't actually run. I run this scheduled job through a batch file. The 1st command in the batch file seems to run. It's an SQL clear command:
sqlcmd -S SFCWEB03\LX_WEB03 -i "C:\Program Files (x86)\LANSA_WEB\X_WIN95\X_LANSA\x_pwe\object\TruncateFiles.sql" -A -d LANSA_WEB
However the LANSA execution happens but it doesn't.
start "regular" /high "C:\Program Files (x86)\LANSA_WEB\X_WIN95\X_LANSA\execute\x_run.exe" FORM=WB_DATAF PART=PWE LANG=ENG USER=Administrator
What's even more weird is when I log into the Server and execute the Task everything runs without a hitch. The task runs as "Administrator." The task is set to run whether the user is logged in or not. It runs with the highest privileges.

I'm at an impasse. My 4:30 alarm is getting old :) Any ideas?

Best,
Chad

Re: Scheduling thru Windows Task Scheduler

Posted: Wed Apr 17, 2019 8:22 am
by MarkDale
Is there anything in the Windows event log? (Control panel --> Administrative Tools --> Event Viewer). Sometimes lansa puts messages there. (or x_err.log of course).
Could you modify your program WB_DATAF to output something right at the start, to see if it actually begins?