VL Framework

This Q&A forum allows users to post and respond to "How Do I Do ....." questions. Please do not use to report (suspected) errors - you must use your regional help desk for this. The information contained in this forum has not been validated by LANSA and, as such, LANSA cannot guarantee the accuracy of the information.
Post Reply
DaveH
Posts: 15
Joined: Tue May 17, 2016 1:35 am

VL Framework

Post by DaveH » Tue Oct 29, 2019 2:48 am

Bemis just upgraded to Lansa V14SP2, now we are receiving an access violation(see attachment). We have on a right click, open a pop window with cut/copy/paste options. The message is received on the right click.

I think its an permissions issue, but I am not sure.


What does this mean exactly and how can it be corrected?

Source Sample
DEFINE_COM Class(#CSCPN.Visual) Name(#CSCPN) Displayposition(2) Left(15) Marginleft(140) Parent(#GPBX_2) Popupmenu(#PMNU_CCP) Tabposition(2) Top(43) Width(385)

DEFINE_COM Class(#PRIM_PMNU) Name(#PMNU_CCP) Autoactions(Cut+Copy+Paste)
DEFINE_COM Class(#PRIM_PMNU) Name(#PMNU_Cpy) Autoactions(Copy)
DEFINE_COM Class(#PRIM_MITM) Name(#MITM_1) Displayposition(1) Parent(#PMNU_CCP)
Attachments
Capture.JPG
Capture.JPG (23.67 KiB) Viewed 295 times

atostaine
Posts: 457
Joined: Wed Jan 20, 2016 7:38 am

Re: VL Framework

Post by atostaine » Tue Oct 29, 2019 4:04 am

Are you running your DLL's from a network server or does each client have it's own copy? If network server, we had to grant write permission to one of the directories. I'll find out which. You could try granting them all and then deleting one by one if I don't get back to you quick enough :D
Art Tostaine

DaveH
Posts: 15
Joined: Tue May 17, 2016 1:35 am

Re: VL Framework

Post by DaveH » Tue Oct 29, 2019 4:56 am

Bemis is running DLL's from a network server.

MarkD
Posts: 630
Joined: Wed Dec 02, 2015 9:56 am

Re: VL Framework

Post by MarkD » Tue Oct 29, 2019 9:54 am

This looks like it should have gone straight to support.
Make sure to send them the dump file.

atostaine
Posts: 457
Joined: Wed Jan 20, 2016 7:38 am

Re: VL Framework

Post by atostaine » Tue Oct 29, 2019 9:56 am

Our network guy said he granted write authority to the root of the Lansa directory. I don’t think that’s necessary but it’s worth a try
Art Tostaine

DaveH
Posts: 15
Joined: Tue May 17, 2016 1:35 am

Re: VL Framework

Post by DaveH » Thu Oct 31, 2019 1:26 am

We gave write authority at the root level, and that did not work.
I should mention that these are window 2016 servers

atostaine
Posts: 457
Joined: Wed Jan 20, 2016 7:38 am

Re: VL Framework

Post by atostaine » Thu Oct 31, 2019 1:44 am

Do you have the same problem when you run it locally? Could be time for support.
Art Tostaine

DaveH
Posts: 15
Joined: Tue May 17, 2016 1:35 am

Re: VL Framework

Post by DaveH » Thu Oct 31, 2019 5:12 am

We do have support involved,

What we have found out:
Created a test form that includes a popup menu with AutoActions defined. When I run the form itself and right-click, there is no issue. I then plugged in the form to our Frameworks. When I ran the for through the frameworks, the Access violation error occurred. - I then removed the AutoActions from the popup menu, but left the popup menu defined. The issue did NOT occur this time.

Issue appears to occur when AutoActions are defined and the object is run through our frameworks.

DaveH
Posts: 15
Joined: Tue May 17, 2016 1:35 am

Re: VL Framework

Post by DaveH » Fri Nov 08, 2019 8:27 am

Lansa provided a hot fix for this issue.

It now works correctly with the Hot Fix installed.

Post Reply