iSeries Execution

This Q&A forum allows users to post and respond to "How Do I Do ....." questions. Please do not use to report (suspected) errors - you must use your regional help desk for this. The information contained in this forum has not been validated by LANSA and, as such, LANSA cannot guarantee the accuracy of the information.
Post Reply
soa
Posts: 287
Joined: Mon Dec 07, 2015 3:15 pm

iSeries Execution

Post by soa » Fri Apr 01, 2016 11:45 am

I've created a simple function and a server module. This works fine in local mode but when I check everything into the iSeries and execute when I press the button which calls the server module nothing happens. Is there some way of displaying any error messages or crash information?

I've also tried running under debug to the iSeries but this does not work. Is there anyway of trouble shooting this?

Finally, is it possible to debug a server module?

Thanks

soa
Posts: 287
Joined: Mon Dec 07, 2015 3:15 pm

Re: iSeries Execution

Post by soa » Fri Apr 01, 2016 2:17 pm

Skip the first issue. I've turned on the chrome developer console and can see a 404 on my server module call.

User avatar
Stewart Marshall
Posts: 417
Joined: Thu Nov 05, 2015 5:25 pm

Re: iSeries Execution

Post by Stewart Marshall » Fri Apr 01, 2016 6:27 pm

Checkin and execute against the IBM i should work without issue. Debugging should also "just work".

If the job is failing i.e. it's crashing, there should be a joblog.

If it's a configuration issue, you'll need to talk to you regional helpdesk.

Regards
Stewart Marshall

Independent IT Consultant
www.marshallfloyd.com.au

User avatar
Jiri
Posts: 43
Joined: Thu Feb 11, 2016 11:41 pm

Re: iSeries Execution

Post by Jiri » Fri Apr 01, 2016 7:29 pm

Two simple notes:
1) This url should test, if your environment (webserver, LANSA...) is set correctly:
http://<yourIBMServer>/<yourLANSALIB>/<yourPartition>/xvlwebtst.html
i.e.:
http://bdat03.bizdata.cz/lansa14/isy/xvlwebtst.html
You can find it from VL-IDE File->Options->Web

2) The Web debug must be enabled, it is option in Web Administrator. As default, it is NOT enabled. The settings is applicable to all LANSA web technologies (Webevent functions, WAMs and VL-Web)

soa
Posts: 287
Joined: Mon Dec 07, 2015 3:15 pm

Re: iSeries Execution

Post by soa » Tue Apr 05, 2016 9:18 am

Just a quick note to say that with the above help all my questions have been resolved. Thanks guys.

Post Reply