VL-Web Widget with form controls

This Q&A forum allows users to post and respond to "How Do I Do ....." questions. Please do not use to report (suspected) errors - you must use your regional help desk for this. The information contained in this forum has not been validated by LANSA and, as such, LANSA cannot guarantee the accuracy of the information.
Post Reply
marco.kam
Posts: 7
Joined: Thu Apr 07, 2016 2:03 am

VL-Web Widget with form controls

Post by marco.kam » Thu Apr 07, 2016 2:12 am

We've been able to create some VL-Web widgets that integrate with third party charting packages (in our case we are using HighCharts) without issue.

However, we are also trying to integrate with other packages that include standard form inputs (input boxes, select dropdowns, radio buttons, etc.).

The issue seems to be that the VL-Web runtime overrides the default behavior of these form inputs. When the application is run, the inputs or selects show up, but you cannot click on them or type into them in the case of input boxes.

Is there a way to make this work?

jyoung
Posts: 642
Joined: Thu Jan 21, 2016 6:43 am
Location: Oklahoma City, OK USA

Re: VL-Web Widget with form controls

Post by jyoung » Mon Apr 11, 2016 10:13 pm

I had the same problem when trying to integrate with a 3rd party credit card processor.

The only way I could make it work, was to create the inputs and selects with RDML and use a custom widget that I would push the data from those inputs into. In my case, the widget would dynamically generate a hidden form that would POST to the 3rd party.

I had a discussion going on regarding it here: http://vlforum.lansa.com.au/viewtopic.php?f=3&t=36

Post Reply