std_toexcel (export to excel) - not working in V14

This Q&A forum allows users to post and respond to "How Do I Do ....." questions. Please do not use to report (suspected) errors - you must use your regional help desk for this. The information contained in this forum has not been validated by LANSA and, as such, LANSA cannot guarantee the accuracy of the information.
Post Reply
LANSADAVE
Posts: 1
Joined: Fri May 17, 2019 11:54 pm

std_toexcel (export to excel) - not working in V14

Post by LANSADAVE » Tue Oct 15, 2019 1:49 am

Hi,

This is for Visual LANSA Version 14 SP2. We are serving WAMs and VLF-WEB off of a Windows server.

I would like to use std_toexcel for a project, that seems to be perfect for, from what I'm reading from the LANSA V14 documentation on Standard Weblets, Chapter 8 - Weblets for XHTML Technology Service.

I'm trying to use the Standard Weblet std_toexcel, on a WAM, to export a list from a Grid I will build from a filter search. I believe this is making a table (tubular data) that the documentation mentions for use of this Weblet.
I'm following all the documentation I can find, placing std_toexcel on the design tab, setting the listname to my GRID List, that I want to make exportable.

I'm not sure what to expect when clicking the 'Export To Excel' button. I expected, possibly a new Excel Spreadsheet to open with my data.

Also, I made sure Activex Controls and Plugins are enabled, in Internet Explorer. Using IE11, and I know there's a possible security issue with that when ActiveX Controls and Plugins are disabled, but I can click the button fine (not disabled). It's just that nothing happens in response.

Any help is much appreciated.

AbelS
Posts: 27
Joined: Wed Nov 16, 2016 1:43 pm
Location: Sydney, Australia
Contact:

Re: std_toexcel (export to excel) - not working in V14

Post by AbelS » Fri Nov 08, 2019 1:47 pm

If there is an error trying to use ActiveX it should pop an alert box indicating an error. Maybe there is an error beforehand. Look at your Javascript console.

BTW, you should consider moving away from using ActiveX (and IE).

Cheers
Abel

atostaine
Posts: 442
Joined: Wed Jan 20, 2016 7:38 am

Re: std_toexcel (export to excel) - not working in V14

Post by atostaine » Wed Nov 13, 2019 4:03 am

AbelS wrote:
Fri Nov 08, 2019 1:47 pm
BTW, you should consider moving away from using ActiveX (and IE).
Cheers
Abel
This worries me too. What replaces integrating with Word & Excel for VL Win?
Art Tostaine

AbelS
Posts: 27
Joined: Wed Nov 16, 2016 1:43 pm
Location: Sydney, Australia
Contact:

Re: std_toexcel (export to excel) - not working in V14

Post by AbelS » Wed Nov 13, 2019 9:54 am

Not VL Win. Just talking about ActiveX inside the browser.

PS: Tested std_toexcel on V14SP2. It works (in IE11 with the proper security settings lowered to enable ActiveX). So, likely something else is breaking earlier and the Javascript to export to Excel is not being run.

Cheers
Abel

Post Reply