Lansa Integrator - Service_Get Trace(*path) for SMTPMailService doesn't work

This Q&A forum allows users to post and respond to "How Do I Do ....." questions. Please do not use to report (suspected) errors - you must use your regional help desk for this. The information contained in this forum has not been validated by LANSA and, as such, LANSA cannot guarantee the accuracy of the information.
Post Reply
dvanoni
Posts: 32
Joined: Wed Dec 02, 2015 3:47 am
Location: Chiasso - Switzerland

Lansa Integrator - Service_Get Trace(*path) for SMTPMailService doesn't work

Post by dvanoni » Tue Nov 05, 2019 3:29 am

Hello everybody! I need to know what is the path of the trace folder when I use SMTPMailService service with Lansa Integrator. So I tried to send the "Service_get trace(*path)" command but I receive an error in the jsm message field: "Unsupported SERVICE_GET TRACE keyword value : SERVICE_GET". I think to have correctly followed the guide but it doesn't work: https://docs.lansa.com/14/en/lansa093/i ... e%7C_____2

How can I fix it?

Thanks

Here the code snippet:

Code: Select all

...
#WRK_jsmcmd := 'Service_Load Service(SMTPMailService) trace(*YES) trace_name(SEND_EMAIL)'
Use Builtin(jsmx_command) With_Args(#WRK_jsmhdle #WRK_jsmcmd) To_Get(#WRK_jsmsts #WRK_jsmmsg)
#WRK_jsmcmd := "Service_Get Trace(*path)"
Use Builtin(jsmx_command) With_Args(#WRK_jsmhdle #WRK_jsmcmd) To_Get(#WRK_jsmsts #WRK_jsmmsg)
...

bark
Posts: 26
Joined: Thu Jan 05, 2017 9:56 am

Re: Lansa Integrator - Service_Get Trace(*path) for SMTPMailService doesn't work

Post by bark » Tue Nov 05, 2019 10:26 am

I recall that this was not working OK and was fixed in V14SP2 so if you're not on that version, that might be the reason.

dvanoni
Posts: 32
Joined: Wed Dec 02, 2015 3:47 am
Location: Chiasso - Switzerland

Re: Lansa Integrator - Service_Get Trace(*path) for SMTPMailService doesn't work

Post by dvanoni » Tue Nov 05, 2019 7:10 pm

Thanks for your reply. We are using V14SP1 and maybe this can be the issue as you said. We will try to update the product and try again.

Thanks

caseywhite
Posts: 105
Joined: Thu May 26, 2016 1:17 am

Re: Lansa Integrator - Service_Get Trace(*path) for SMTPMailService doesn't work

Post by caseywhite » Wed Nov 06, 2019 5:53 am

Strange. So it is not just ending up in the standard /jsm/instance/trace folder? That must be a bug. I am on 14SP0 and see it appear in /jsm/instance/trace.

Theo de Bruin
Posts: 9
Joined: Wed Feb 10, 2016 8:41 pm

Re: Lansa Integrator - Service_Get Trace(*path) for SMTPMailService doesn't work

Post by Theo de Bruin » Wed Nov 13, 2019 9:28 pm

Did you try with CAPITALS ??

as in

#JSMXCMD := 'SERVICE_GET TRACE(*PATH)'
Use Builtin(jsmx_command) With_Args(#JSMXHDLE1 #JSMXCMD) To_Get(#JSMXSTS #JSMXMSG)
#Tracepath := #JSMXMSG

dvanoni
Posts: 32
Joined: Wed Dec 02, 2015 3:47 am
Location: Chiasso - Switzerland

Re: Lansa Integrator - Service_Get Trace(*path) for SMTPMailService doesn't work

Post by dvanoni » Thu Nov 14, 2019 1:16 am

Hi Theo,

thanks for your reply.

it doesn't work also with CAPITALS...

Post Reply