Search found 31 matches

by bark
Tue Jul 28, 2020 2:46 pm
Forum: Questions & Answers
Topic: Anyone storing VL Dev licenses on a windows server?
Replies: 2
Views: 316

Re: Anyone storing VL Dev licenses on a windows server?

I may not be understanding your setup correctly but why not get a VLN for your own PC? You apply your VLN to your own PC and in the development license studio, set your host server to your own PC as the host type (not local), refresh and press the button to use licenses server <your PC>. Or perhaps ...
by bark
Thu Feb 06, 2020 11:49 am
Forum: Questions & Answers
Topic: Max. length BCC field using SMTPMailService?
Replies: 4
Views: 1704

Re: Max. length BCC field using SMTPMailService?

Since a smaller list is OK, it would suggest a limit. Check the trace files generated by JSM to see if you can see a truncated/corrupted email address. If its always truncated on the same one, then it would suggest a limit. If you then remove that one address and all addresses after it and its OK, y...
by bark
Thu Feb 06, 2020 11:22 am
Forum: Questions & Answers
Topic: Activex error for one user
Replies: 13
Views: 2994

Re: Activex error for one user (RESOLVED)

I think what you are saying is that the end users still have the same version of MS Word but the TypeLibID on your own dev PC has changed so when you build and deploy, it fails for the users. Correct? So what has changed on your PC since this was last OK? Did you get a new update of Office 2016? Hav...
by bark
Fri Jan 10, 2020 5:26 pm
Forum: Questions & Answers
Topic: Where did BIF GET_FILE_INFO go?
Replies: 3
Views: 641

Re: Where did BIF GET_FILE_INFO go?

Some clarity required...for example, what do you mean by missing?
Is it that when you use the USE command in an RDML function, it isn't available? Or that the program bi@p129 doesn't exist?
is it an existing function that is falling over at runtime or are you developing?
and what version is this?
by bark
Wed Dec 11, 2019 2:57 pm
Forum: Questions & Answers
Topic: Where to Start?
Replies: 8
Views: 1330

Re: Where to Start?

I endorse JYoungs approach. There's no getting away from the fact that if you are new to LANSA, you will have to do some learning and the tutorials would be the best way of gaining understanding and confidence. Get on the latest version of VL and go straight to vl web, which is what VLF-One piggy ba...
by bark
Thu Nov 14, 2019 10:17 am
Forum: Questions & Answers
Topic: VL-IDE slow
Replies: 28
Views: 4575

Re: VL-IDE slow

In my experience, the only way of making headway with random IDE crashes is to zip up the (enormous) dump file and get it sent to the devs. Often, they can pinpoint the issue and provide a fix. So, that would be my suggestion for your random crashes (but if you don't like to apply hotfixes, you migh...
by bark
Tue Nov 05, 2019 10:26 am
Forum: Questions & Answers
Topic: Lansa Integrator - Service_Get Trace(*path) for SMTPMailService doesn't work
Replies: 5
Views: 856

Re: Lansa Integrator - Service_Get Trace(*path) for SMTPMailService doesn't work

I recall that this was not working OK and was fixed in V14SP2 so if you're not on that version, that might be the reason.
by bark
Wed Jul 31, 2019 10:57 am
Forum: Questions & Answers
Topic: Activex error for one user
Replies: 13
Views: 2994

Re: Activex error for one user

Regarding this bit "When I click to update the ProgID the IDE crashes."
Check out this https://www.lansa.com/support/notes/p0463.htm
ActiveX crash in Visual LANSA editor after applying Windows 10 update

I know there has been a round of Windows updates recently so this is a distinct possibility.
by bark
Thu May 09, 2019 2:40 pm
Forum: Questions & Answers
Topic: Windows 10 Upgrade 1809 - Compile and Build
Replies: 3
Views: 11658

Re: Windows 10 Upgrade 1809 - Compile and Build

We've got a few Win 10 PCs here with Update 1809 and building and compiling is fine.
Assuming you will have to do this again at some point, it might be worth sending the build/compile logs to the LANSA support guys now so they can see if anything jumps out before you go around again.
HTH
by bark
Fri Mar 01, 2019 2:43 pm
Forum: Questions & Answers
Topic: Ancestor fields in group_by and def_list
Replies: 6
Views: 3416

Re: Ancestor fields in group_by and def_list

Hi Joe

The expression error in the #MyGroupBy looks wrong and looks like a defect that you should report to LANSA support.

HTH
bark
by bark
Thu Feb 28, 2019 2:54 pm
Forum: Questions & Answers
Topic: Lansa web About page error V14SP2
Replies: 9
Views: 6520

Re: Lansa web About page error V14SP2

If I stop my database service in Windows control panel -> services, I get the same 0x1c (28) as you. So, that's the area to focus on. Have you tried the ODBC Data sources Admin, select your data source/Configure -> Test Data Source? If that connects successfully, using the Change button in the error...
by bark
Thu Feb 28, 2019 11:44 am
Forum: Questions & Answers
Topic: Lansa web About page error V14SP2
Replies: 9
Views: 6520

Re: Lansa web About page error V14SP2

You should start the Web Administrator from the Settings and Administration folder. Open the local webplugin.conf config file and from the Tools menu, there is a Test option. Use this to run a test and see whats failing/not set up correctly. You can even check the details, make changes and restart I...
by bark
Thu Jan 10, 2019 12:52 pm
Forum: Questions & Answers
Topic: Tutorial - Web Application Modules (WAMs) - 404
Replies: 6
Views: 3388

Re: Tutorial - Web Application Modules (WAMs) - 404

I agree with the others that have posted here already. For new web development, don't proceed with WAMs as you are starting with a technology from 2005 and this isn't the technology that LANSA will be pushing on with in terms of future development and enhancements. The WAM technology is in a 'fixes ...
by bark
Wed Dec 12, 2018 11:30 am
Forum: Questions & Answers
Topic: EPC142030 Missing IDE Features
Replies: 5
Views: 5023

Re: EPC142030 Missing IDE Features

Update: Item 2 is a defect introduced in this EPC and needs to be fixed for the next delivery.
by bark
Wed Dec 12, 2018 10:29 am
Forum: Questions & Answers
Topic: EPC142030 Missing IDE Features
Replies: 5
Views: 5023

Re: EPC142030 Missing IDE Features

Hi Joe
1. I noticed they were gone too. They've been moved under History on the ribbon of the Home tab.
Note sure about your item two.
cheers!
by bark
Mon Nov 05, 2018 4:20 pm
Forum: Questions & Answers
Topic: Task ID Grayed out?
Replies: 3
Views: 2121

Re: Task ID Grayed out?

If I recall correctly, if an object is all black but task grayed out, that means that the object has been checked out for read-only and they grayed out task is what its locked to on the server. But if an object is all gray, that means the object doesn't exist locally but is on the server only (and t...
by bark
Mon Aug 27, 2018 5:14 pm
Forum: Questions & Answers
Topic: LANSA Integrator
Replies: 2
Views: 1495

Re: LANSA Integrator

Try to remove the SOAPAgent from the problem and to focus on the HTTP TCP/IP connection.
Use the HTTPService to make either:
a GET request to http://www.webservicex.net/stockquote.asmx
or a POST request using some SOAP XML.
This would tell you if it was a network issue.
by bark
Tue Aug 14, 2018 11:11 am
Forum: Questions & Answers
Topic: Loading an other file containing a '.' in the name
Replies: 3
Views: 1661

Re: Loading an other file containing a '.' in the name

An 'old but gold' issue.
As KevinW says, use the PERMFILOVR. Its still in the LANSA documentation if you search for it.
I recall that this tip on the web site covers the steps to do
https://www.lansa.com/support/tips/t0261.htm
cheers
bark
by bark
Tue Aug 14, 2018 10:27 am
Forum: Questions & Answers
Topic: VL IDE - Check Out Readonly Tables and Fields
Replies: 7
Views: 2382

Re: VL IDE - Check Out Readonly Tables and Fields

And further to Arts sound advice, you should do your 'mass export' of the repository for read-only. Essentially, you just want to fill up the local slave repository with all objects. The developer can then check out for update anything to be worked on.
cheers
bark
by bark
Mon Jun 18, 2018 3:01 pm
Forum: Questions & Answers
Topic: 14 SP2 - new publishing/using new webservices
Replies: 2
Views: 1435

Re: 14 SP2 - new publishing/using new webservices

Hi Steve

Hope this reply isn't too late for you but I recently got some material and examples through support for this. I was told that the material was still being improved so perhaps you should touch base with support and get the latest.
cheers
bk