compilation fail. as/400

This Q&A forum allows users to post and respond to "How Do I Do ....." questions. Please do not use to report (suspected) errors - you must use your regional help desk for this. The information contained in this forum has not been validated by LANSA and, as such, LANSA cannot guarantee the accuracy of the information.
Post Reply
noamp
Posts: 11
Joined: Thu Nov 02, 2017 9:29 pm

compilation fail. as/400

Post by noamp » Thu Nov 02, 2017 9:56 pm

hey,
i am using lansa for ibm i (as/400) and i changed a program (the program was working and compiled before) and added 1 fetch command and i was sended for compilation.
now the compilation was failed and i dont know why, i tagged the log file of the problem.
if anyone can help me to understand where the problem is i be thankful . thanks.
Attachments
problem09.pdf
(40.32 KiB) Downloaded 134 times

kno_dk
Posts: 89
Joined: Tue Feb 23, 2016 12:00 am

Re: compilation fail. as/400

Post by kno_dk » Fri Nov 03, 2017 12:56 am

Hi

When you check in then set the "produce DDS/RPG listing" to checked and then see the source on the IBM i.

noamp
Posts: 11
Joined: Thu Nov 02, 2017 9:29 pm

Re: compilation fail. as/400

Post by noamp » Mon Nov 06, 2017 11:09 pm

hey, i dont understand well, where i set the "produce DDS/RPG listing" to checked? i dont know how to do that and that do you mean.?
thanks.

User avatar
lawingo
Posts: 50
Joined: Fri Dec 04, 2015 6:41 am

Re: compilation fail. as/400

Post by lawingo » Tue Nov 07, 2017 6:09 am

Have you checked your Library List of the user that is compiling the object? Does it include the library of the object you are trying to fetch data from? Just a thought.

MarkDale
Posts: 102
Joined: Wed Dec 02, 2015 10:06 am

Re: compilation fail. as/400

Post by MarkDale » Tue Nov 07, 2017 8:58 am

When you check in the function for compile, you should see a dialog like this:
Compile dialogue.PNG
Compile dialogue.PNG (54.8 KiB) Viewed 2688 times
That is where you specify the produce DDS/RPG listing.

noamp
Posts: 11
Joined: Thu Nov 02, 2017 9:29 pm

Re: compilation fail. as/400

Post by noamp » Wed Nov 08, 2017 11:09 pm

hey,
yes. i fetch from library from library list. when i remove the fetch command the compile was succeeded- and when i added back- the compiler was not succeeded.

the window that you show me does not exist on os / 400, that is different lansa interface from the pc.

bark
Posts: 24
Joined: Thu Jan 05, 2017 9:56 am

Re: compilation fail. as/400

Post by bark » Thu Nov 09, 2017 11:16 am

Hi

The joblog has this error message
Message . . . . : Program error detected while processing function PGRCV09
An internal error in program DC@P3107 was trapped during an attempted compile
of function PGRCV09. Please report this problem to your EDP department or
product vendor as soon as possible.

You might want to take the advice of the message in the joblog and report this to your local LANSA representative. Include your LANSA version information and CPU information as well as the joblog and the RDML/RPG and DDS source listings.

The online help shows you how to generate the RDML/RPG and DDS source listings
http://docs.lansa.com/14/en/lansa010/in ... n%7C_____2
Produce RDML / RPG and DDS source listings . . . NO / NO YES, NO

noamp
Posts: 11
Joined: Thu Nov 02, 2017 9:29 pm

Re: compilation fail. as/400

Post by noamp » Tue Nov 21, 2017 6:53 pm

thank!.

Post Reply